<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>American Jewish World  &raquo; Blog Archive  Jews vie in St. Paul, Minneapolis mayoral races - American Jewish World</title>

<meta name="generator" content="WordPress 4.8.2" /> <!-- leave this for stats -->

<link rel="stylesheet" href="http://ajwnews.com/wp-content/themes/AJW/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="American Jewish World RSS Feed" href="http://ajwnews.com/feed/" />
<link rel="pingback" href="http://ajwnews.com/xmlrpc.php" />


<!-- This site is optimized with the Yoast SEO plugin v4.9 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Carrying on a Minnesota Jewish tradition of civic engagement, Tom Goldstein is running for St. Paul mayor and Jacob Frey is in the Minneapolis mayoral race."/>
<link rel="canonical" href="http://ajwnews.com/mayoral/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Jews vie in St. Paul, Minneapolis mayoral races - American Jewish World" />
<meta property="og:description" content="Carrying on a Minnesota Jewish tradition of civic engagement, Tom Goldstein is running for St. Paul mayor and Jacob Frey is in the Minneapolis mayoral race." />
<meta property="og:url" content="http://ajwnews.com/mayoral/" />
<meta property="og:site_name" content="American Jewish World" />
<meta property="article:publisher" content="https://www.facebook.com/pages/American-Jewish-World/57917046180" />
<meta property="article:tag" content="Allianz Life Insurance Co. of North America" />
<meta property="article:tag" content="American Jewish World" />
<meta property="article:tag" content="Arthur Naftalin" />
<meta property="article:tag" content="Betsy Hodges" />
<meta property="article:tag" content="Chris Coleman" />
<meta property="article:tag" content="DFL" />
<meta property="article:tag" content="Faegre and Benson" />
<meta property="article:tag" content="Faegre Baker Daniels" />
<meta property="article:tag" content="Halunen Law" />
<meta property="article:tag" content="Jacob Frey" />
<meta property="article:tag" content="Lawrence “Larry” Cohen" />
<meta property="article:tag" content="Minneapolis" />
<meta property="article:tag" content="Minnesota" />
<meta property="article:tag" content="Mordecai Specktor" />
<meta property="article:tag" content="Norm Coleman" />
<meta property="article:tag" content="Phyllis Kahn" />
<meta property="article:tag" content="Sarah Clark" />
<meta property="article:tag" content="St. Paul" />
<meta property="article:tag" content="Tom Goldstein" />
<meta property="article:section" content="Front Page" />
<meta property="article:published_time" content="2017-10-18T11:39:18-05:00" />
<meta property="article:modified_time" content="2017-10-19T13:02:49-05:00" />
<meta property="og:updated_time" content="2017-10-19T13:02:49-05:00" />
<meta property="fb:admins" content="1032574473" />
<meta property="og:image" content="http://ajwnews.com/wp-content/uploads/2017/10/Tom-Goldstein-St.-Paul-10.20-221x300.gif" />
<meta property="og:image" content="http://ajwnews.com/wp-content/uploads/2017/10/Jacob-Frey-for-Mpls-10.20-228x300.gif" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Carrying on a Minnesota Jewish tradition of civic engagement, Tom Goldstein is running for St. Paul mayor and Jacob Frey is in the Minneapolis mayoral race." />
<meta name="twitter:title" content="Jews vie in St. Paul, Minneapolis mayoral races - American Jewish World" />
<meta name="twitter:site" content="@MNJewishWorld" />
<meta name="twitter:image" content="http://ajwnews.com/wp-content/uploads/2017/10/Tom-Goldstein-St.-Paul-10.20-221x300.gif" />
<meta name="twitter:creator" content="@MNJewishWorld" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="American Jewish World &raquo; Jews vie in St. Paul, Minneapolis mayoral races Comments Feed" href="http://ajwnews.com/mayoral/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/ajwnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='avhec-widget-css'  href='http://ajwnews.com/wp-content/plugins/extended-categories-widget/4.2/css/avh-ec.widget.css?ver=3.10.0-dev.1' type='text/css' media='all' />
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga'></script>
<link rel='https://api.w.org/' href='http://ajwnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://ajwnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://ajwnews.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.2" />
<link rel='shortlink' href='http://ajwnews.com/?p=27752' />
<link rel="alternate" type="application/json+oembed" href="http://ajwnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fajwnews.com%2Fmayoral%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://ajwnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fajwnews.com%2Fmayoral%2F&#038;format=xml" />
<style type="text/css">#cat-posts-263334312{display:none}</style>
</head>
<body>

<div id="container">
<!-- using the AJW theme! -->
	<div id="page">
	
		<div id="header">
			<h1 style="display:none"><a href="">American Jewish World</a></h1>
			<a id="pic" href="/"></a>

						<div id="nav">
				<ul>
					<li ><a href="http://ajwnews.com">Home</a></li>
					<li><a href="/category/news">News</a></li>
					<li><a href="/category/editorial">Editorial</a></li>
					<li><a href="/local-deals">Local Deals</a></li>
					<li><a href="/subscribe">Subscribe</a></li>
					<li><a href="/about">About/Info</a></li>
				</ul>
			</div>
			<br class="clear"/>
		<div class="ad"><a href="http://ajwnews.com/we-appreciate-our-advertisers/" class="textad">DIRECTORY OF AMERICAN JEWISH WORLD ADVERTISERS</a></a>		</div>
</div>

		<div id="content_box">
		
			<div id="content">
				
								
					<div class="navigation">
						<div class="previous"><a href="http://ajwnews.com/seth-kibel/" rel="prev">Trump’s rise moves  songwriter Seth Kibel to despair</a></div>
						<div class="next"><a href="http://ajwnews.com/church-and-state/" rel="next">Church and State is timely show for MJTC</a></div>
					</div>
				
					<div class="post" id="post-27752">
						<h4>Wednesday, October 18th, 2017...11:39 am</h4>
						<h2>Jews vie in St. Paul, Minneapolis mayoral races</h2>
				
						<div class="entry">
							<span class="jump"><a href="http://ajwnews.com/mayoral/#comments">Jump to Comments</a></span>
							<h3 style="text-align: center;"><span style="color: #993300;"><em>Carrying on a Minnesota Jewish tradition of civic engagement, Tom Goldstein is running for St. Paul mayor and Jacob Frey is in the Minneapolis mayoral race</em></span></h3>
<p>By MORDECAI SPECKTOR</p>
<p>In the 1960s, Minneapolis had its first and only Jewish mayor. Arthur Naftalin (1915-2005) served as the Mill City’s mayor from 1961 to 1969.</p>
<div id="attachment_27753" style="width: 231px" class="wp-caption alignnone"><img class="wp-image-27753 size-medium" src="http://ajwnews.com/wp-content/uploads/2017/10/Tom-Goldstein-St.-Paul-10.20-221x300.gif" alt="" width="221" height="300" /><p class="wp-caption-text"><strong>Tom Goldstein (Photo: Courtesy of Tom Goldstein for St. Paul)</strong></p></div>
<p>And St. Paul has had two Jewish mayors. Lawrence “Larry” Cohen (1933-2016) was mayor from 1972 to 1976. And Norm Coleman served as the capital city’s mayor from 1994 to 2002. (Coleman was elected as a DFL partisan, then switched to the Republican Party in 1996, and was reelected in 1997.)</p>
<p>If lightning strikes on Nov. 7, Election Day, the Twin Cities could have two Jewish mayors serving at the same time.</p>
<p>In the Minneapolis mayoral race, Jacob Frey, 36, a DFLer elected to the City Council in 2013, is making waves with his well-funded campaign. He’s one of 15 candidates challenging the incumbent mayor, Betsy Hodges.</p>
<p>The race in St. Paul is not quite so crowded. The incumbent, Chris Coleman, is running for governor in 2018; and 10 candidates are vying for mayor, including Tom Goldstein, 60, a former St. Paul School Board member who is known for his activism against public subsidies for sports stadiums.</p>
<p>Both Frey and Goldstein talked with the Jewish World last week about their campaigns.</p>
<p>“I’m not trying to be the third Jewish mayor of St. Paul,” Goldstein commented in the midst of a phone interview. “I’m trying to be the best candidate.”</p>
<p>A former proprietor of a sports memorabilia shop and the publisher of the esteemed baseball journal Elysian Fields Quarterly, Goldstein is a native of the Washington, D.C., area. He came to Minnesota to attend Carleton College and settled in for the long haul.</p>
<p>“It’s the fact that I’m running an issues-oriented campaign that’s most important to me,” he told the Jewish World.</p>
<p><span id="more-27752"></span>Among the issues he mentioned are rebuilding the city’s infrastructure, providing increase financial support for education and affordable housing, and “doing something very specific about job creation so that we’re bringing firms and entrepreneurs to St. Paul and actually creating jobs.”</p>
<p>Goldstein, who worked on the Bernie Sanders presidential campaign, also talks up “universal broadband” access in St. Paul, and advocates a high-tech corridor along the University Avenue route of the Green Line light rail.</p>
<p>“We have to take care of our streets and not forsake the neighborhoods,” he added “There’s been so much disinvestment in the last 15 years, because our politicians have been so focused on giving out subsidies for developments that we have over $20 million per year that goes to pay off bonds for tax increment financing and doesn’t go into the city treasury.”</p>
<p>Goldstein says that elected officials are “constantly looking for funds — unless someone wants to build a stadium or some kind of glitzy development, then we can find that money. But when it comes to modernizing a rec center or promoting community development or providing start-up funds for a business, we don’t have those resources. I think our priorities are skewed.”</p>
<p>Of particular Jewish interest, Goldstein has criticized granting naming rights for the new pro soccer stadium in St. Paul to Allianz Life Insurance Co. of North America.</p>
<p>The parent company of Allianz was embroiled in a scandal for not paying off insurance policies taken out by Jews who died in the Holocaust. Goldstein pointed out that the issue came up when Allianz was looking to buy naming rights for the NFL stadium in East Rutherford, N.J., which is used by the Giants and the Jets.</p>
<p>The Associated Press reported that negotiations stopped in 2008, “after the deal was criticized by Jewish groups and Holocaust survivors. The company said then it had atoned for its past history and should not be judged by its World War II record. The venue later was named MetLife Stadium.”</p>
<p>Allianz Field, the future home of Minnesota United, is scheduled to open in 2019.</p>
<div id="attachment_27754" style="width: 238px" class="wp-caption alignleft"><img class="wp-image-27754 size-medium" src="http://ajwnews.com/wp-content/uploads/2017/10/Jacob-Frey-for-Mpls-10.20-228x300.gif" alt="" width="228" height="300" /><p class="wp-caption-text"><strong>Jacob Frey (Photo: Courtesy of Jacob Frey for Our City)</strong></p></div>
<p>Crossing the river, Mayor Betsy Hodges, who was elected in 2013, is facing a pack of DFL challengers, including Jacob Frey, a native of suburban Washington, D.C., who ran in the Twin Cities Marathon and became enamored with Minneapolis. After graduating from law school at Villanova University, Frey, who pursued a career as a professional long-distance runner, took a job with the Faegre and Benson law firm (now Faegre Baker Daniels), and later at Halunen Law.</p>
<p>Representing the Third Ward on the City Council, Frey also is on the board of the Jewish Community Relations Council of Minnesota and the Dakotas. He said that he has attended both Temple Israel and Shir Tikvah, Reform shuls in Minneapolis.</p>
<p>“The Jewish community was so welcoming here in Minneapolis,” he commented. “When I moved out here, it was heartwarming to be welcomed by a loving and warm community of Jews. And those relations have just grown deeper.”</p>
<p>And Frey mentioned that the Jewish community also welcomed his wife, Sarah Clark, who is planning on converting to Judaism.</p>
<p>Asked why he wants to be mayor of Minneapolis, Frey responded, “Minneapolis has been in the news for all the wrong reasons lately and we need a fresh start. I want to make sure every bit of potential in this city is realized. We’ve had a significant uptick in violent crime, and some of the worst police-community relations in a while, and we can change that.”</p>
<p>Frey also mentioned “a dearth” of affordable housing in Minneapolis, and the need for job creation.</p>
<p>Regarding the incumbent mayor, Frey said that he and Hodges differ on “a few” issues. “We’re all Democrats, and the mayor is not an ideological position — it’s one of leadership. While I respect the mayor, no, I don’t feel she’s led when things have been tough and controversial.”</p>
<p>A recent Star Tribune profile of Frey quoted former state legislator Phyllis Kahn: “If you want one word that most fits [Frey], I think ‘ambitious’ is the word. That’s not really negative, and no, it’s not really positive either. But my guess is people who are ambitious get more done over time.”</p>
<p>“I think Minneapolis could use some ambition,” Frey responded, when asked about Kahn’s assessment. “I’m ambitious to get things done, and I always thought that was a positive thing.”</p>
<p>On his campaign website, Frey has posted his “five-point vision for Minneapolis,” which includes the previously mentioned issues of affordable housing, jobs and dealing with “both crime and police misconduct.” There’s also a point about putting Minneapolis on track “to be one of the greenest cities in America.”</p>
<p>Asked how his vision statement relates to the marked racial disparities in Minneapolis — the large gaps between whites and people of color in unemployment, income and homeownership, etc. — Frey said, “Every facet in my platform incorporates a lens of racial equity. Affordable housing — we know that communities of color are disproportionately deprived housing… we’ve lost 10,000 units of affordable housing in just the last 15 years, and it’s not like things were rosy in 2002.”</p>
<p>Frey emphasized that it’s not just a matter of rhetoric or philosophy, but rather “putting our money where our mouth is. Everybody deserves to live in a great city, and that is very quickly not becoming the case.”</p>
<p>Minneapolis, and the greater Twin Cities, have been roiled over recent years by the police killings of unarmed black men —notably, the cases of Jamar Clark, in north Minneapolis, and Philando Castile, in Falcon Heights.</p>
<p>“I believe in police accountability, and we know that communities of color, specifically, black men, are not always treated fairly by our police,” said Frey, who advocates for “more extensive implicit bias training.” He also mentioned that police need better training in how to exhaust all alternatives before resorting to deadly force.</p>
<p>“I believe there should be a rebuttable presumption of misconduct, if the officer fails to turn on the body camera and something bad happens,” he added. “A lot of times, race comes into play in all these issues.”</p>
<p>The Minneapolis DFL failed to endorse a candidate for mayor this year. Frey came in second; Ray Dehn, a state legislator from north Minneapolis, came in first, and Hodges was third in the voting.</p>
<p>It’s an educated guess who will win the Minneapolis mayor’s race. It’s not outlandish to think that Minneapolis could end up with its second Jewish mayor.</p>
<p><em>(American Jewish World, 10.20.17)</em></p>
				
											
							<div class="post_meta">
								<p class="num_comments">No Comments</p>
								<p class="tagged">Filed under <a href="http://ajwnews.com/category/frontpage/" rel="category tag">Front Page</a>, <a href="http://ajwnews.com/" rel="category tag">News</a></p>
							</div>
						</div>
					</div>
					
					
<!-- You can start editing here. -->

<div id="comments">

		
	   
			<!-- If comments are open, but there are no comments. -->
			
		 		
	
		
	<h2 class="form_head">Leave a Reply</h2>
	
		
	<form action="http://ajwnews.com/wp-comments-post.php" method="post" id="comment_form">
	
				
			<p><input type="text" class="text_input" name="author" id="author" value="" tabindex="1" /><label for="author">Name (required)</label></p>
			<p><input type="text" class="text_input" name="email" id="email" value="" tabindex="2" /><label for="email">Mail (will not be published) (required)</label></p>
			<p><input type="text" class="text_input" name="url" id="url" value="" tabindex="3" /><label for="url">Website</label></p>
		
				
		<!--<p><small><strong>XHTML:</strong> You can use these tags: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </small></p>-->
		
		<p><textarea class="text_area" name="comment" id="comment" rows="10" tabindex="4"></textarea></p>	
		<p>
			<input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />
			<input type="hidden" name="comment_post_ID" value="27752" />
		</p>
		<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4fd65aeb01" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="37"/></p>	
	</form>
	
		
	
</div>				
							
			</div>
			
			<div>

<!--  REMOVED TWITTER BUTTON - Doesn't play well with Local Deals - David Woolley
<a href="http://www.twitter.com/MNJewishWorld"><img src="http://twitter-badges.s3.amazonaws.com/twitter-a.png" alt="Follow MNJewishWorld on Twitter" style="margin-bottom: 8px;" /></a>
-->

	<ul id="sidebar">
<li id="super_recent_posts_widget-2" class="widget super_recent_posts"><h2 class="widgettitle"><a href="http://ajwnews.com/category/bluebox/"> </a></h2>
                <div class="super_recent_posts_item">
                    <a href="http://ajwnews.com/seth-kibel/" title="Trump’s rise moves  songwriter Seth Kibel to despair" class="super_recent_posts_item_title">Trump’s rise moves  songwriter Seth Kibel to despair</a>

                                        <div class="post-entry">
                                                        <p><p>Seth Kibel, a Washington, D.C.-based musician, says he was “shellshocked” by the results of the 2016 presidential election: “I had a hard time processing what had happened.” The multi-instrumentalist (sax, flute and clarinet) played in the various jazz and klezmer ensembles, but the rise of Donald Trump led him to shift gears. He wrote nine </p>
 <a href="http://ajwnews.com/seth-kibel/" class="more-link"></a></p>
                                                        </div>
                        <div class="clear">&nbsp;</div>
                    
                </div>
            
            
        </li>
<li id="text-316128684" class="widget widget_text">			<div class="textwidget"><a href="mailto:business@ajwnews.com" class="textad">The AJW is a legal newspaper in Hennepin County. We can publish your Certificate of Assumed Name or other legal notice. Email Mordecai at: editor [at] ajwnews [dot] com.</a></div>
		</li>
<li id="text-316128685" class="widget widget_text">			<div class="textwidget"><a href="mailto:business@ajwnews.com" class="textad">Read our biweekly print edition: Try it FREE for 3 months. No strings. Contact: business@ajwnews.com</a></div>
		</li>
<li id="extended-categories-2" class="widget widget_extended-categories"><!-- AVH Extended Categories version 3.10.0-dev.1 | http://blog.avirtualhome.com/wordpress-plugins/ --><h2 class="widgettitle">Categories</h2>
<ul>	<li class="cat-item cat-item-6106"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/advertisers/" title="View all posts filed under AJW Advertisers">AJW Advertisers</a></div>
</li>
	<li class="cat-item cat-item-53"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/arts/" title="View all posts filed under Arts">Arts</a></div>
</li>
	<li class="cat-item cat-item-31"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/bluebox/" title="View all posts filed under Blue Box">Blue Box</a></div>
</li>
	<li class="cat-item cat-item-6620"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/business-scene/" title="View all posts filed under Business Scene">Business Scene</a></div>
</li>
	<li class="cat-item cat-item-28"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/editorial/" title="View all posts filed under Editorial">Editorial</a></div>
</li>
	<li class="cat-item cat-item-30 current-cat"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/frontpage/" title="View all posts filed under Front Page">Front Page</a></div>
</li>
	<li class="cat-item cat-item-34"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/israel-blog/" title="View all posts filed under Israel Blog">Israel Blog</a></div>
</li>
	<li class="cat-item cat-item-54"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/news/israel-news/" title="View all posts filed under Israel/Mideast">Israel/Mideast</a></div>
</li>
	<li class="cat-item cat-item-100"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/opinion/letters/" title="View all posts filed under Letters to the Editor">Letters to the Editor</a></div>
</li>
	<li class="cat-item cat-item-6623"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/lifestyle/" title="View all posts filed under Lifestyle">Lifestyle</a></div>
</li>
	<li class="cat-item cat-item-33"><div class="avhec-widget-line"><a href="http://ajwnews.com/" title="View all posts filed under News">News</a></div>
</li>
	<li class="cat-item cat-item-29"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/opinion/" title="View all posts filed under Opinion">Opinion</a></div>
</li>
	<li class="cat-item cat-item-1"><div class="avhec-widget-line"><a href="http://ajwnews.com/category/uncategorized/" title="View all posts filed under Uncategorized">Uncategorized</a></div>
</li>
</ul></li>
<li id="text-316128683" class="widget widget_text">			<div class="textwidget"><a href="/directory" style="font-size: 1.4em;">Jewish Community Directory</a></div>
		</li>
<li id="archives-2" class="widget widget_archive"><h2 class="widgettitle">Archives</h2>
		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://ajwnews.com/2017/10/'> October 2017 &nbsp;(14)</option>
	<option value='http://ajwnews.com/2017/09/'> September 2017 &nbsp;(14)</option>
	<option value='http://ajwnews.com/2017/08/'> August 2017 &nbsp;(26)</option>
	<option value='http://ajwnews.com/2017/07/'> July 2017 &nbsp;(16)</option>
	<option value='http://ajwnews.com/2017/06/'> June 2017 &nbsp;(17)</option>
	<option value='http://ajwnews.com/2017/05/'> May 2017 &nbsp;(24)</option>
	<option value='http://ajwnews.com/2017/04/'> April 2017 &nbsp;(18)</option>
	<option value='http://ajwnews.com/2017/03/'> March 2017 &nbsp;(18)</option>
	<option value='http://ajwnews.com/2017/02/'> February 2017 &nbsp;(18)</option>
	<option value='http://ajwnews.com/2017/01/'> January 2017 &nbsp;(15)</option>
	<option value='http://ajwnews.com/2016/12/'> December 2016 &nbsp;(17)</option>
	<option value='http://ajwnews.com/2016/11/'> November 2016 &nbsp;(27)</option>
	<option value='http://ajwnews.com/2016/10/'> October 2016 &nbsp;(17)</option>
	<option value='http://ajwnews.com/2016/09/'> September 2016 &nbsp;(15)</option>
	<option value='http://ajwnews.com/2016/08/'> August 2016 &nbsp;(20)</option>
	<option value='http://ajwnews.com/2016/07/'> July 2016 &nbsp;(17)</option>
	<option value='http://ajwnews.com/2016/06/'> June 2016 &nbsp;(22)</option>
	<option value='http://ajwnews.com/2016/05/'> May 2016 &nbsp;(17)</option>
	<option value='http://ajwnews.com/2016/04/'> April 2016 &nbsp;(23)</option>
	<option value='http://ajwnews.com/2016/03/'> March 2016 &nbsp;(18)</option>
	<option value='http://ajwnews.com/2016/02/'> February 2016 &nbsp;(23)</option>
	<option value='http://ajwnews.com/2016/01/'> January 2016 &nbsp;(17)</option>
	<option value='http://ajwnews.com/2015/12/'> December 2015 &nbsp;(25)</option>
	<option value='http://ajwnews.com/2015/11/'> November 2015 &nbsp;(17)</option>
	<option value='http://ajwnews.com/2015/10/'> October 2015 &nbsp;(25)</option>
	<option value='http://ajwnews.com/2015/09/'> September 2015 &nbsp;(22)</option>
	<option value='http://ajwnews.com/2015/08/'> August 2015 &nbsp;(18)</option>
	<option value='http://ajwnews.com/2015/07/'> July 2015 &nbsp;(25)</option>
	<option value='http://ajwnews.com/2015/06/'> June 2015 &nbsp;(18)</option>
	<option value='http://ajwnews.com/2015/05/'> May 2015 &nbsp;(21)</option>
	<option value='http://ajwnews.com/2015/04/'> April 2015 &nbsp;(26)</option>
	<option value='http://ajwnews.com/2015/03/'> March 2015 &nbsp;(21)</option>
	<option value='http://ajwnews.com/2015/02/'> February 2015 &nbsp;(18)</option>
	<option value='http://ajwnews.com/2015/01/'> January 2015 &nbsp;(19)</option>
	<option value='http://ajwnews.com/2014/12/'> December 2014 &nbsp;(22)</option>
	<option value='http://ajwnews.com/2014/11/'> November 2014 &nbsp;(21)</option>
	<option value='http://ajwnews.com/2014/10/'> October 2014 &nbsp;(28)</option>
	<option value='http://ajwnews.com/2014/09/'> September 2014 &nbsp;(20)</option>
	<option value='http://ajwnews.com/2014/08/'> August 2014 &nbsp;(20)</option>
	<option value='http://ajwnews.com/2014/07/'> July 2014 &nbsp;(32)</option>
	<option value='http://ajwnews.com/2014/06/'> June 2014 &nbsp;(24)</option>
	<option value='http://ajwnews.com/2014/05/'> May 2014 &nbsp;(26)</option>
	<option value='http://ajwnews.com/2014/04/'> April 2014 &nbsp;(31)</option>
	<option value='http://ajwnews.com/2014/03/'> March 2014 &nbsp;(24)</option>
	<option value='http://ajwnews.com/2014/02/'> February 2014 &nbsp;(26)</option>
	<option value='http://ajwnews.com/2014/01/'> January 2014 &nbsp;(29)</option>
	<option value='http://ajwnews.com/2013/12/'> December 2013 &nbsp;(30)</option>
	<option value='http://ajwnews.com/2013/11/'> November 2013 &nbsp;(29)</option>
	<option value='http://ajwnews.com/2013/10/'> October 2013 &nbsp;(36)</option>
	<option value='http://ajwnews.com/2013/09/'> September 2013 &nbsp;(20)</option>
	<option value='http://ajwnews.com/2013/08/'> August 2013 &nbsp;(25)</option>
	<option value='http://ajwnews.com/2013/07/'> July 2013 &nbsp;(26)</option>
	<option value='http://ajwnews.com/2013/06/'> June 2013 &nbsp;(21)</option>
	<option value='http://ajwnews.com/2013/05/'> May 2013 &nbsp;(27)</option>
	<option value='http://ajwnews.com/2013/04/'> April 2013 &nbsp;(24)</option>
	<option value='http://ajwnews.com/2013/03/'> March 2013 &nbsp;(33)</option>
	<option value='http://ajwnews.com/2013/02/'> February 2013 &nbsp;(27)</option>
	<option value='http://ajwnews.com/2013/01/'> January 2013 &nbsp;(26)</option>
	<option value='http://ajwnews.com/2012/12/'> December 2012 &nbsp;(19)</option>
	<option value='http://ajwnews.com/2012/11/'> November 2012 &nbsp;(23)</option>
	<option value='http://ajwnews.com/2012/10/'> October 2012 &nbsp;(31)</option>
	<option value='http://ajwnews.com/2012/09/'> September 2012 &nbsp;(28)</option>
	<option value='http://ajwnews.com/2012/08/'> August 2012 &nbsp;(36)</option>
	<option value='http://ajwnews.com/2012/07/'> July 2012 &nbsp;(23)</option>
	<option value='http://ajwnews.com/2012/06/'> June 2012 &nbsp;(25)</option>
	<option value='http://ajwnews.com/2012/05/'> May 2012 &nbsp;(32)</option>
	<option value='http://ajwnews.com/2012/04/'> April 2012 &nbsp;(26)</option>
	<option value='http://ajwnews.com/2012/03/'> March 2012 &nbsp;(29)</option>
	<option value='http://ajwnews.com/2012/02/'> February 2012 &nbsp;(22)</option>
	<option value='http://ajwnews.com/2012/01/'> January 2012 &nbsp;(19)</option>
	<option value='http://ajwnews.com/2011/12/'> December 2011 &nbsp;(21)</option>
	<option value='http://ajwnews.com/2011/11/'> November 2011 &nbsp;(24)</option>
	<option value='http://ajwnews.com/2011/10/'> October 2011 &nbsp;(27)</option>
	<option value='http://ajwnews.com/2011/09/'> September 2011 &nbsp;(32)</option>
	<option value='http://ajwnews.com/2011/08/'> August 2011 &nbsp;(33)</option>
	<option value='http://ajwnews.com/2011/07/'> July 2011 &nbsp;(21)</option>
	<option value='http://ajwnews.com/2011/06/'> June 2011 &nbsp;(27)</option>
	<option value='http://ajwnews.com/2011/05/'> May 2011 &nbsp;(30)</option>
	<option value='http://ajwnews.com/2011/04/'> April 2011 &nbsp;(25)</option>
	<option value='http://ajwnews.com/2011/03/'> March 2011 &nbsp;(25)</option>
	<option value='http://ajwnews.com/2011/02/'> February 2011 &nbsp;(29)</option>
	<option value='http://ajwnews.com/2011/01/'> January 2011 &nbsp;(22)</option>
	<option value='http://ajwnews.com/2010/12/'> December 2010 &nbsp;(31)</option>
	<option value='http://ajwnews.com/2010/11/'> November 2010 &nbsp;(18)</option>
	<option value='http://ajwnews.com/2010/10/'> October 2010 &nbsp;(25)</option>
	<option value='http://ajwnews.com/2010/09/'> September 2010 &nbsp;(32)</option>
	<option value='http://ajwnews.com/2010/08/'> August 2010 &nbsp;(22)</option>
	<option value='http://ajwnews.com/2010/07/'> July 2010 &nbsp;(26)</option>
	<option value='http://ajwnews.com/2010/06/'> June 2010 &nbsp;(21)</option>
	<option value='http://ajwnews.com/2010/05/'> May 2010 &nbsp;(19)</option>
	<option value='http://ajwnews.com/2010/04/'> April 2010 &nbsp;(25)</option>
	<option value='http://ajwnews.com/2010/03/'> March 2010 &nbsp;(25)</option>
	<option value='http://ajwnews.com/2010/02/'> February 2010 &nbsp;(24)</option>
	<option value='http://ajwnews.com/2010/01/'> January 2010 &nbsp;(20)</option>
	<option value='http://ajwnews.com/2009/12/'> December 2009 &nbsp;(22)</option>
	<option value='http://ajwnews.com/2009/11/'> November 2009 &nbsp;(27)</option>
	<option value='http://ajwnews.com/2009/10/'> October 2009 &nbsp;(24)</option>
	<option value='http://ajwnews.com/2009/09/'> September 2009 &nbsp;(27)</option>
	<option value='http://ajwnews.com/2009/08/'> August 2009 &nbsp;(24)</option>
	<option value='http://ajwnews.com/2009/07/'> July 2009 &nbsp;(19)</option>
	<option value='http://ajwnews.com/2009/06/'> June 2009 &nbsp;(27)</option>
	<option value='http://ajwnews.com/2009/05/'> May 2009 &nbsp;(21)</option>
	<option value='http://ajwnews.com/2009/04/'> April 2009 &nbsp;(56)</option>
	<option value='http://ajwnews.com/2009/03/'> March 2009 &nbsp;(22)</option>
	<option value='http://ajwnews.com/2009/02/'> February 2009 &nbsp;(23)</option>
	<option value='http://ajwnews.com/2009/01/'> January 2009 &nbsp;(26)</option>
	<option value='http://ajwnews.com/2008/12/'> December 2008 &nbsp;(13)</option>
	<option value='http://ajwnews.com/2008/11/'> November 2008 &nbsp;(14)</option>
	<option value='http://ajwnews.com/2008/10/'> October 2008 &nbsp;(3)</option>
	<option value='http://ajwnews.com/2008/09/'> September 2008 &nbsp;(3)</option>
	<option value='http://ajwnews.com/2008/08/'> August 2008 &nbsp;(4)</option>
	<option value='http://ajwnews.com/2008/07/'> July 2008 &nbsp;(3)</option>

		</select>
		</li>
<li id="pages-2" class="widget widget_pages"><h2 class="widgettitle">Info</h2>
		<ul>
			<li class="page_item page-item-5"><a href="http://ajwnews.com/about/">About the AJW</a></li>
<li class="page_item page-item-18"><a href="http://ajwnews.com/advertising/">Advertising Information</a></li>
<li class="page_item page-item-9353"><a href="http://ajwnews.com/ajw-submission-guidelines/">AJW Submission Guidelines</a></li>
<li class="page_item page-item-24570"><a href="http://ajwnews.com/diy-ads/">Do-it-Yourself Web Ads</a></li>
<li class="page_item page-item-16"><a href="http://ajwnews.com/directory/">Jewish Community Directory</a></li>
<li class="page_item page-item-24568"><a href="http://ajwnews.com/local-deals/">Local Deals</a></li>
<li class="page_item page-item-17"><a href="http://ajwnews.com/subscribe/">Subscription Information</a></li>
		</ul>
		</li>
<li id="calendar-2" class="widget widget_calendar"><h2 class="widgettitle">Monthly View</h2>
<div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>October 2017</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://ajwnews.com/2017/09/">&laquo; Sep</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr><td>1</td><td>2</td><td>3</td><td><a href="http://ajwnews.com/2017/10/04/" aria-label="Posts published on October 4, 2017">4</a></td><td>5</td><td>6</td><td>7</td>
	</tr>
	<tr>
		<td>8</td><td>9</td><td>10</td><td><a href="http://ajwnews.com/2017/10/11/" aria-label="Posts published on October 11, 2017">11</a></td><td>12</td><td>13</td><td>14</td>
	</tr>
	<tr>
		<td>15</td><td>16</td><td>17</td><td><a href="http://ajwnews.com/2017/10/18/" aria-label="Posts published on October 18, 2017">18</a></td><td>19</td><td id="today">20</td><td>21</td>
	</tr>
	<tr>
		<td>22</td><td>23</td><td>24</td><td>25</td><td>26</td><td>27</td><td>28</td>
	</tr>
	<tr>
		<td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="4">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></li>
<li id="text-316128682" class="widget widget_text">			<div class="textwidget"><a href="/feed" style="text-align:center"><h1>RSS Feed <img src="/wp-content/themes/AJW/images/feed_icon.png"/> </h1> </a></div>
		</li>
<li id="search-2" class="widget widget_search"><form method="get" id="search_form" action="http://ajwnews.com/">
	<p style="margin-bottom: 5px;"><input type="text" class="text_input" value="" name="s" id="s" /></p>
	<p style="margin-bottom: 0;"><input type="submit" id="searchsubmit" value="Search" /></p>
</form>
</li>

	</ul>
</div>			
		</div>

		<div id="footer">

<a href="http://www.twitter.com/MNJewishWorld"><img src="http://twitter-badges.s3.amazonaws.com/twitter-a.png" alt="Follow MNJewishWorld on Twitter"/></a>

			<p>&copy; 2009 American Jewish World.</p>
		</div>
	
	</div>
</div>
<script>
    jQuery(document).ready(function () {
		jQuery.post('http://ajwnews.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var F = new Function ( response );
			return( F() );
		});
    });
</script><script type='text/javascript' src='http://ajwnews.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.2'></script>
<script type='text/javascript' src='http://ajwnews.com/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
</body>
</html>
